多年青岛网站建设经验,专业青岛网站设计公司青岛网站制作公司关于我们 | 客户服务欢迎来到青岛网站建设公司青华互联!
年轻,更要脱颖而出
对于网站建设,我们有活力,有态度
我们的优势: 专业网络公司,网站设计师量身定制 配备阿里云主机,BGP多线,高速访问 保障网站数据稳定、安全 免费提供快速ICP备案 承诺24小时快速解决网站简单问题

关于dede后台验证码错误的解决办法

更新时间:2012-08-17 14:52   已阅读: 次 |  作者:青华互联  来源:青岛网站建设

1.用v56之前版权include/vdimgck.php覆盖现在的文件,测试可行,不过验证码样式就回到以前版本的,喜欢新版的朋友可能会不舒服;

2.data/safe/inc_safe_config.php打开头一行

$safe_gdopen = '1,2,3,4,5,6';
修改为
$safe_gdopen = '1,2,3,4,5';
去掉6,即关闭后台验证码选项,测试可行,治标不治本;

 

3.下面说说的我的解决办法
出现验证码错误的情况,是更新官方0814的补丁后
检查一下,发现问题出在common.func.php这个文件上面
这是之前老版本的文件,更新说明里也没提到这个文件,可能是官方疏忽多放了导致的。
打开它,注意600行左右两个函数

function GetCkVdValue()
{
 @session_start();
 return isset($_SESSION['dd_ckstr']) ? $_SESSION['dd_ckstr'] : '';
}
//php某些版本有Bug,不能在同一作用域中同时读session并改注销它,因此调用后需执行本函数
function ResetVdValue()
{
 @session_start();
 $_SESSION['dd_ckstr'] = '';
 $_SESSION['dd_ckstr_last'] = '';
}
并不适用V56版本的新验证码
正确的应该是
function GetCkVdValue()
{
 @session_start();
 return isset($_SESSION['securimage_code_value']) ? $_SESSION['securimage_code_value'] : '';
}
//php某些版本有Bug,不能在同一作用域中同时读session并改注销它,因此调用后需执行本函数
function ResetVdValue()
{
 @session_start();
 $_SESSION['securimage_code_value'] = '';
}
另外,此文件中还缺失一些安全过滤函数。

 

所以,解决办法是:下载V56GBK最新版本,找到include/common.func.php,覆盖你网站现有的即可,相对完美。


文章引用:http://www.qinghuahulian.com/news/webzhishi/132.html
青岛网站建设
电话咨询
0532-80812129
186-532-19163
青岛网站制作
青岛网站建设手机站
返回顶部